CRAN Package Check Results for Package bigGP

Last updated on 2021-10-21 07:49:48 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.1-6 13.22 38.56 51.78 WARN
r-devel-linux-x86_64-debian-gcc 0.1-6 9.09 30.47 39.56 WARN
r-devel-linux-x86_64-fedora-clang 0.1-6 79.25 WARN
r-devel-linux-x86_64-fedora-gcc 0.1-6 67.76 WARN
r-patched-linux-x86_64 0.1-6 14.08 37.99 52.07 WARN
r-patched-solaris-x86 0.1-6 96.40 OK
r-release-linux-x86_64 0.1-6 10.92 37.51 48.43 WARN
r-release-macos-arm64 0.1-6 ERROR
r-release-macos-x86_64 0.1-6 ERROR
r-oldrel-macos-x86_64 0.1-6 ERROR

Check Details

Version: 0.1-6
Check: top-level files
Result: WARN
     Output from running autoreconf:
     configure.ac:13: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:13: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:13: the top level
     configure.ac:32: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:32: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:32: the top level
     configure.ac:54: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:54: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:54: the top level
     configure.ac:203: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:203: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:203: the top level
     configure.ac:530: warning: AC_OUTPUT should be used without arguments.
     configure.ac:530: You should run autoupdate.
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-patched-linux-x86_64, r-release-linux-x86_64

Version: 0.1-6
Check: top-level files
Result: WARN
     Output from running autoreconf:
     configure.ac:13: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:13: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:13: the top level
     configure.ac:32: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:32: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:32: the top level
     configure.ac:54: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:54: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:54: the top level
     configure.ac:203: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:203: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:203: the top level
     configure.ac:530: warning: AC_OUTPUT should be used without arguments.
     configure.ac:530: You should run autoupdate.
     configure.ac:13: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:13: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:13: the top level
     configure.ac:32: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:32: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:32: the top level
     configure.ac:54: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:54: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:54: the top level
     configure.ac:203: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:203: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:203: the top level
     configure.ac:530: warning: AC_OUTPUT should be used without arguments.
     configure.ac:530: You should run autoupdate.
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc

Version: 0.1-6
Check: compiled code
Result: NOTE
    File ‘bigGP/libs/bigGP.so’:
     Found no calls to: ‘R_registerRoutines’, ‘R_useDynamicSymbols’
    
    It is good practice to register native routines and to disable symbol
    search.
    
    See ‘Writing portable packages’ in the ‘Writing R Extensions’ manual.
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc

Version: 0.1-6
Check: package dependencies
Result: ERROR
    Package required but not available: ‘Rmpi’
    
    See section ‘The DESCRIPTION file’ in the ‘Writing R Extensions’
    manual.
Flavors: r-release-macos-arm64, r-release-macos-x86_64, r-oldrel-macos-x86_64