CRAN Package Check Results for Package audio

Last updated on 2021-11-26 19:52:43 CET.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.1-8 6.48 23.13 29.61 WARN
r-devel-linux-x86_64-debian-gcc 0.1-10 3.82 18.30 22.12 NOTE
r-devel-linux-x86_64-fedora-clang 0.1-10 47.57 OK
r-devel-linux-x86_64-fedora-gcc 0.1-10 36.85 OK
r-devel-windows-x86_64-new-UL 0.1-8 15.00 51.00 66.00 WARN
r-devel-windows-x86_64-new-TK 0.1-8 WARN
r-devel-windows-x86_64-old 0.1-8 10.00 35.00 45.00 WARN
r-patched-linux-x86_64 0.1-8 5.14 22.61 27.75 WARN
r-patched-solaris-x86 0.1-10 47.30 OK
r-release-linux-x86_64 0.1-8 WARN
r-release-macos-arm64 0.1-8 WARN
r-release-macos-x86_64 0.1-8 WARN
r-release-windows-ix86+x86_64 0.1-8 17.00 40.00 57.00 WARN
r-oldrel-macos-x86_64 0.1-8 WARN
r-oldrel-windows-ix86+x86_64 0.1-10 13.00 32.00 45.00 OK

Check Details

Version: 0.1-8
Check: top-level files
Result: WARN
     Output from running autoreconf:
     configure.ac:4: warning: The macro `AC_CONFIG_HEADER' is obsolete.
     configure.ac:4: You should run autoupdate.
     ./lib/autoconf/status.m4:719: AC_CONFIG_HEADER is expanded from...
     configure.ac:4: the top level
Flavors: r-devel-linux-x86_64-debian-clang, r-patched-linux-x86_64, r-release-linux-x86_64

Version: 0.1-8
Check: compiled code
Result: NOTE
    File 'audio/libs/audio.so':
     Found non-API call to R: 'R_checkActivity'
    
    Compiled code should not call non-API entry points in R.
    
    See 'Writing portable packages' in the 'Writing R Extensions' manual.
Flavors: r-devel-linux-x86_64-debian-clang, r-patched-linux-x86_64, r-release-linux-x86_64

Version: 0.1-10
Check: compiled code
Result: NOTE
    File ‘audio/libs/audio.so’:
     Found non-API call to R: ‘R_checkActivity’
    
    Compiled code should not call non-API entry points in R.
    
    See ‘Writing portable packages’ in the ‘Writing R Extensions’ manual.
Flavor: r-devel-linux-x86_64-debian-gcc

Version: 0.1-8
Check: whether package can be installed
Result: WARN
    Found the following significant warnings:
     wmm.c:428:2: warning: initialization of 'struct audio_instance * (*)(struct SEXPREC *, float, int)' from incompatible pointer type 'wmm_instance_t * (*)(struct SEXPREC *, float, int)' {aka 'struct wmm_instance * (*)(struct SEXPREC *, float, int)'} [-Wincompatible-pointer-types]
     wmm.c:429:2: warning: initialization of 'struct audio_instance * (*)(struct SEXPREC *, float, int, int)' from incompatible pointer type 'wmm_instance_t * (*)(struct SEXPREC *, float, int, int)' {aka 'struct wmm_instance * (*)(struct SEXPREC *, float, int, int)'} [-Wincompatible-pointer-types]
Flavors: r-devel-windows-x86_64-new-UL, r-devel-windows-x86_64-new-TK, r-devel-windows-x86_64-old, r-release-windows-ix86+x86_64

Version: 0.1-8
Check: whether package can be installed
Result: WARN
    Found the following significant warnings:
     au.c:222:8: warning: 'AudioHardwareGetProperty' is deprecated: first deprecated in macOS 10.6 [-Wdeprecated-declarations]
     au.c:229:8: warning: 'AudioDeviceGetProperty' is deprecated: first deprecated in macOS 10.6 [-Wdeprecated-declarations]
     au.c:375:2: warning: incompatible pointer types initializing 'struct audio_instance *(*)(SEXP, float, int)' (aka 'struct audio_instance *(*)(struct SEXPREC *, float, int)') with an expression of type 'au_instance_t *(SEXP, float, int)' (aka 'struct au_instance *(struct SEXPREC *, float, int)') [-Wincompatible-pointer-types]
     au.c:376:2: warning: incompatible pointer types initializing 'struct audio_instance *(*)(SEXP, float, int, int)' (aka 'struct audio_instance *(*)(struct SEXPREC *, float, int, int)') with an expression of type 'au_instance_t *(SEXP, float, int, int)' (aka 'struct au_instance *(struct SEXPREC *, float, int, int)') [-Wincompatible-pointer-types]
Flavors: r-release-macos-arm64, r-release-macos-x86_64, r-oldrel-macos-x86_64